► SkyUI Error Code 錯誤代碼

技術文章轉載收錄 :3 授權已問

► Error Code 1-> The Skyrim Script Extender (SKSE) 沒有起到作用......

◎問題

你沒有安裝SKSE (或是你安裝錯誤)。

◎解法

從此網站(http://skse.silverlock.org/) 下載SKSE並且按照指導與Readme來安裝。

如果你遇到SKSE的安裝或運行的問題,請看Gopher的影片導引:https://www.youtube.com/watch?v=xTGnQIiNVqA

► Error Code 2-> SKSE 是舊版的......

◎問題

你用的SKSE版本是舊版的。你有可能是因為更新了SkyUI卻沒有好好地更新SKSE。

◎解法

如前面所描述的解決方案安裝最新的SKSE版本。

► Error Code 3-> SKSE scripts(腳本)是舊版的......

◎問題

設置SKSE需要兩個步驟:安裝二進位文件和Papyrus scripts。

你的Papyrus沒有與SKSE文件配合。

要不是你忘了安裝就是沒有更新,或是一個Creation Kit的更新覆寫了那些檔案。

◎解法 引述SKSE Readme檔案:

1. 複製 .dll 及 .exe 檔案去至你的Skyrim目錄。

那通常在你的Program Files資料夾下面Steam\SteamApps\common\skyrim。

如果你看到檔名為TESV和SkyrimLauncher,那就是正確的位置。

別像一般的Mod一樣複製到Data資料夾內。

而"src"資料夾只對程式人員有用,大多數使用者可以忽略它。

2. 複製 Data\Scripts 裡面的 .pex 檔案到你安裝位置的 Data\Scripts 資料夾。這 .pex 檔案是SKSE的使用者所需要的。

確認一下你是否忘記第二步驟。

Error Code 4-> 你的 Papyrus INI 設置無效...... ◎問題

一個或多個,你的Papyrus INI的數值被設置為無效值。裡面有幾個tweak和INI設定在發送一些超出範圍的數值。

因此,SkyUI或是其他以SKSE為基礎的Mod作用不正常。

◎解法

找到 My Documents/My Games/Skyrim/Skyrim.ini 用筆記本打開並重新設置以下值到各自的默認值

[Papyrus]

iMinMemoryPageSize=128

iMaxMemoryPageSize=512

iMaxAllocatedMemoryBytes=76800

你也許也需要在 SkyrimCustom.ini 裡面更改這些數值,如果那個檔案存在的話,會在同一個目錄裡面。

有關這些設置的含義與詳細信息,請參閱http://www.creationkit.com/INI_Settings_(Papyrus) 另外,如果你認為你知道更好的:你並不。參閱 Papyrus開發員的建議。備註1:如果即使你的Papyrus INI的設置是正確還是收到此錯誤代碼,請重新安裝SKSE。

這可能是因為你的一些SKSE腳本已經被覆蓋,這可能會導致INI值測試失敗。

備註 2:如果你SKSE安裝正確而且INI設置也正確,請檢查以下數值:

[Archive]bInvalidateOlderFiles=1

此值如為0將導致SKSE停止工作並導致INI值測試失敗。

Error Code 5-> 不兼容的選單文件...... 此錯誤有兩個潛在原因。

◎問題 A

你安裝 SkyUI 3.0 或更新版之前沒有完整移除舊版。

◎解法 A

確認你移除了舊版 SkyUI全部的檔案,然後再安裝一次新版。

使用Nexus Mod Manager安裝SkyUI比較方便,因為它會檢測並列出從舊版SkyUI遺留的衝突文件。

(此原理只是重複檔案會提示是否覆蓋)

◎問題 B

還有另外一個MOD,它覆蓋一個 SkyUI 正在使用的特定選單文件。

◎解法 B

你必須兩者擇一。如果你希望其他MOD要能覆蓋SkyUI某些選單文件,你可以在SkyUI配置選單(高級頁)單獨禁用這些警告訊息。

Error Code 6-> 選單文件版本不匹配...... ◎問題

SkyUI腳本和其他文件的版本不匹配。

這有可能發生,如果你動到SkyUI.bsa。

◎解法

從您的資料夾中刪除任何不能適當搭配的SkyUI文件。

原文地址:https://forum.gamer.com.tw/C.php?bsn=2526&snA=30470